After parameter for pagination Error


after parameter for pagination seems doesn't work, here is my test request

curl '' \
  -H 'Accept: */*' \
  -H 'Accept-Language: en-GB,en-US;q=0.9,en;q=0.8,zh-CN;q=0.7,zh;q=0.6' \
  -H 'Cache-Control: no-cache' \
  -H 'Connection: keep-alive' \
  -H 'DNT: 1' \
  -H 'Origin: http://localhost:3000' \
  -H 'Pragma: no-cache' \
  -H 'Referer: http://localhost:3000/' \
  -H 'Sec-Fetch-Dest: empty' \
  -H 'Sec-Fetch-Mode: cors' \
  -H 'Sec-Fetch-Site: cross-site' \
  -H 'User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/100.0.4896.127 Safari/537.36' \
  -H 'content-type: application/json' \
  -H 'sec-ch-ua: " Not A;Brand";v="99", "Chromium";v="100", "Google Chrome";v="100"' \
  -H 'sec-ch-ua-mobile: ?0' \
  -H 'sec-ch-ua-platform: "macOS"' \
  --data-raw $'{"query":"query followingQuery($identity: String\u0021, $after: String) {\\n  identity(address: $identity, network: ETH) {\\n    followerCount\\n    followers(first: 50, after: $after) {\\n      pageInfo {\\n        hasNextPage\\n        hasPreviousPage\\n        __typename\\n      }\\n      list {\\n        address\\n        __typename\\n      }\\n      __typename\\n    }\\n    __typename\\n  }\\n}","operationName":"followingQuery","variables":{"identity":"0x148d59faf10b52063071eddf4aaf63a395f2d41c","after":"0x34c0fd5f1dc4929549ad414026fc68060549f9c8"}}' \

Answers 1

The after parameter value should be the endCursor from last query, or empty (the defalut value is "-1") for the first page query, not the wallet address. We use string number for now. e.g. first: 50 queries 1st-50th followers, and first: 50, after: "49" queries 51st - 100th followers.